Skip to main content

Node.js Multiple Vulnerabilities

Release Date: 20 Feb 2023 3753 Views

RISK: Medium Risk

TYPE: Servers - Other Servers

TYPE: Other Servers

Multiple vulnerabilities have been identified in Node.js, a remote attacker can exploit these vulnerabilities to trigger remote code execution, security restriction bypass, elevation of privilege and denial of service on the targeted system.


  • Remote Code Execution
  • Security Restriction Bypass
  • Denial of Service
  • Elevation of Privilege

System / Technologies affected

  • Node.js versions prior to 14.21.3 (LTS)
  • Node.js versions prior to 16.19.1 (LTS)
  • Node.js versions prior to 18.14.1 (LTS)
  • Node.js versions prior to 19.6.1


Before installation of the software, please visit the vendor web-site for more details.

  • Update to Node.js version 14.21.3 (LTS)
  • Update to Node.js version 16.19.1 (LTS)
  • Update to Node.js version 18.14.1 (LTS)
  • Update to Node.js version 19.6.1

Vulnerability Identifier


Related Link