跳至主內容

Node.js 多個漏洞

發佈日期: 2023年02月20日 1536 觀看次數

風險: 中度風險

類型: 伺服器 - 其他伺服器

類型: 其他伺服器

於 Node.js 發現一些漏洞,遠端攻擊者可利用這些漏洞,於目標系統觸發遠端執行任意程式碼、繞過保安限制、權限提升及阻斷服務。


影響

  • 遠端執行程式碼
  • 繞過保安限制
  • 阻斷服務
  • 權限提升

受影響之系統或技術

  • Node.js 14.21.3 以前的版本
  • Node.js 16.19.1 (LTS) 以前的版本
  • Node.js 18.14.1 (LTS) 以前的版本
  • Node.js 19.6.1 以前的版本

解決方案

在安裝軟體之前,請先瀏覽供應商之網站,以獲得更多詳細資料。

  • 更新至 Node.js 14.21.3 (LTS) 版本
  • 更新至 Node.js 16.19.1 (LTS) 版本
  • 更新至 Node.js 18.14.1 (LTS) 版本
  • 更新至 Node.js 19.6.1 版本

漏洞識別碼


資料來源


相關連結

https://nodejs.org/en/blog/vulnerability/february-2023-security-releases/