Skip to main content

WhatsApp Multiple Vulnerabilities

Last Update Date: 4 Sep 2020 11:22 Release Date: 4 Sep 2020 2497 Views

RISK: Medium Risk

TYPE: Clients - Im, Chat & Voip

TYPE: Im, Chat & Voip

Multiple vulnerabilities were identified in Whatsapp, a remote attacker could exploit some of these vulnerabilities to trigger elevation of privilege, remote code execution, cross-site scripting and bypass security restriction on the targeted system.


Impact

  • Cross-Site Scripting
  • Elevation of Privilege
  • Remote Code Execution
  • Security Restriction Bypass

System / Technologies affected

  • WhatsApp for Android prior to v2.20.35
  • WhatsApp Business for Android prior to v2.20.20
  • WhatsApp for iPhone prior to v2.20.30
  • WhatsApp Business for iPhone prior to v2.20.30
  • WhatsApp Desktop versions prior to v0.3.4932

Solutions

Before installation of the software, please visit the vendor web-site for more details.

  • Apply fixes issued by the vendor:
    Update to the latest versions of WhatsApp

 


Vulnerability Identifier


Source


Related Link