Skip to main content

WhatsApp Buffer Overflow Vulnerability

Last Update Date: 14 May 2019 18:26 Release Date: 14 May 2019 4848 Views

RISK: High Risk

TYPE: Clients - Im, Chat & Voip

TYPE: Im, Chat & Voip

A vulnerability was identified in WhatsApp, a remote attacker could exploit this vulnerability to trigger remote code execution and bypass security restriction on the targeted system.

Notes: The vulnerability CVE-2019-3568 is being used in scattered exploit.


Impact

  • Remote Code Execution
  • Security Restriction Bypass

System / Technologies affected

  • WhatsApp for Android prior to version 2.19.134
  • WhatsApp Business for Android prior to version 2.19.44
  • WhatsApp for iOS prior to version 2.19.51
  • WhatsApp Business for iOS prior to version 2.19.51
  • WhatsApp for Windows Phone prior to version 2.18.348
  • WhatsApp for Tizen prior to version 2.18.15

Solutions

Before installation of the software, please visit the software manufacturer web-site for more details.


Vulnerability Identifier


Source


Related Link