Skip to main content

Sun Solaris Flash Player Multiple Vulnerabilities

Last Update Date: 28 Jan 2011 Release Date: 18 Mar 2009 4289 Views

RISK: Medium Risk

Multiple vulnerabilities have been identified in Sun Solaris, which could be exploited by attackers to compromise a vulnerable system. These issues are caused by errors in Flash.


Impact

  • Denial of Service
  • Remote Code Execution

System / Technologies affected

  • Sun Solaris 10
  • Sun Opensolaris

Solutions

  • Workaround
    Remove the Adobe Flash Player ("SUNW-flash-player-plugin" package) using the pkgrm utility until a patch is available.
  • Resolution
    These issues are addressed in the following releases:
  • Sun OpenSolaris (SPARC) - Upgrade to build snv_111 or later
  • Sun OpenSolaris (x86) - Upgrade to build snv_111 or later
  • A final resolution is pending completion for Solaris 10.
  • For details, please refer to http://sunsolve.sun.com/search/document.do?assetkey=1-66-254909-1


Vulnerability Identifier


Source


Related Link