Skip to main content

Node.js Multiple Vulnerabilities

Release Date: 9 Jul 2024 1904 Views

RISK: Medium Risk

TYPE: Servers - Other Servers

TYPE: Other Servers

Multiple vulnerabilities have been identified in Node.js. A remote attacker can exploit these vulnerabilities to trigger remote code execution and security restriction bypass on the targeted system.


Impact

  • Remote Code Execution
  • Security Restriction Bypass

System / Technologies affected

  • Node.js versions prior to 18.20.4 (LTS)
  • Node.js versions prior to 20.15.1 (LTS)
  • Node.js versions prior to 22.4.1 (Current)

Solutions

Before installation of the software, please visit the vendor web-site for more details.

  • Update to Node.js version 18.20.4 (LTS)
  • Update to Node.js version 20.15.1 (LTS) 
  • Update to Node.js version 22.4.1 (Current)

Vulnerability Identifier


Source


Related Link