Skip to main content

Apache Commons Text Remote Code Execution Vulnerabilities

Last Update Date: 18 Oct 2022 17:10 Release Date: 18 Oct 2022 10336 Views

RISK: High Risk

TYPE: Servers - Web Servers

TYPE: Web Servers

A vulnerability has been identified in Apache Commons Text. A remote user can exploit some of these vulnerabilities to trigger remote code execution on the targeted system. 

 

Notes: Proof Of Concept Exploit Code Is Publicly Available for CVE-2022-42889


Impact

  • Remote Code Execution

System / Technologies affected

  • Apache Commons Text version 1.5 through 1.9

Solutions

Before installation of the software, please visit the vendor web-site for more details.

 

Apply fixes issued by the vendor:

  • Update to Apache Commons Text version 1.10.0

Vulnerability Identifier


Source


Related Link