HKCert
  

WhatsApp Buffer Overflow Vulnerability

Release Date: 14 / 05 / 2019
Last Update: 14 / 05 / 2019
Criticality Level:  


A vulnerability was identified in WhatsApp, a remote attacker could exploit this vulnerability to trigger remote code execution and bypass security restriction on the targeted system.

Notes: The vulnerability CVE-2019-3568 is being used in scattered exploit.

  • Remote Code Execution
  • Security Restriction Bypass
  • WhatsApp for Android prior to version 2.19.134
  • WhatsApp Business for Android prior to version 2.19.44
  • WhatsApp for iOS prior to version 2.19.51
  • WhatsApp Business for iOS prior to version 2.19.51
  • WhatsApp for Windows Phone prior to version 2.18.348
  • WhatsApp for Tizen prior to version 2.18.15

Before installation of the software, please visit the software manufacturer web-site for more details.